"Failed to load!"

Incident Report for Mechanic

Resolved

This incident has been resolved. 🌱
Posted Aug 08, 2025 - 16:47 UTC

Monitoring

All systems green; keeping a close eye on the space.
Posted Aug 08, 2025 - 15:02 UTC

Update

Confirming: this issue appears limited to Mechanic's web-facing surfaces:

* Merchant-facing Shopify app (https://admin.shopify.com/store/:yours/apps/mechanic)
* Public task library (https://tasks.mechanic.dev/)
* Deprecated webhook ingress point (http://usemechanic.com/webhooks/:yours; please use https://webhooks.mechanic.dev/)

These surfaces have been restored! And we're zeroing in on the root cause.
Posted Aug 08, 2025 - 14:32 UTC

Investigating

Hey folks! It looks like Mechanic's merchant-facing app interface has been failing to load for the last ~2 hours. We're investigating.

I'm marking this as a "partial" outage, because it seems like the actual run pipeline is performing normally.

Please join us in Slack, let us know how this is impacting you, and keep your finger on the collective pulse as we resolve:

https://slack.mechanic.dev/
Posted Aug 08, 2025 - 14:26 UTC
This incident affected: Mechanic.