Higher-than-usual latency

Incident Report for Mechanic

Resolved

Round trips (RTTs) are back to normal, averaging 2-3s. Events are being marked "completed" closer to 6min late now, rather than 10min. We'll keep working on that bit, but are closing this issue out now that platform throughput is back to normal.
Posted Feb 25, 2025 - 00:25 UTC

Identified

Mechanic's run processing time is a bit elevated:

* We're seeing event-to-action round trips taking around 6 seconds, which is higher than we prefer.
* Events are being marked "completed" about 10 minutes late. This isn't an operational issue, but it is irregular.

Mechanic *is* fully available, just a little slower than usual.

We're working with our data provider on this.

If you've got questions, please email team@usemechanic.com. To compare notes with other users, come join https://slack.mechanic.dev/. To keep an eye on platform performance, see https://status.mechanic.dev/. :)
Posted Feb 24, 2025 - 20:16 UTC
This incident affected: Mechanic.