Pipeline slowdown

Incident Report for Mechanic

Resolved

This incident has been resolved.
Posted Jan 24, 2025 - 15:59 UTC

Monitoring

Pipeline efficiency is holding steady, and we're capably carrying the increased volume created by backlogged run queues.
Posted Jan 24, 2025 - 14:53 UTC

Identified

We've narrowed down the issue, and have been poking at it with variously-sized-but-all-highly-technical sticks.

As a result, pipeline throughput is back to normal efficiency levels. We're not out of the woods yet, but things are much improved.
Posted Jan 24, 2025 - 14:18 UTC

Investigating

Mechanic's run pipeline is running uncommonly slowly! 🐢 We're investigating.

Please see https://status.mechanic.dev/ for live platform metrics.
Posted Jan 24, 2025 - 13:50 UTC
This incident affected: Mechanic.